Neaktivní hodnoceníNeaktivní hodnoceníNeaktivní hodnoceníNeaktivní hodnoceníNeaktivní hodnocení
 

upozorneni phpPo aktualizaci na Joomla 3.8.11 se vám pravděpodobně v administraci vašich webových stránek v Joomla! začalo zobrazovat výše uvedené upozornění, že používáte zastaralou verzi PHP. Verze se liší podle verze PHP použité na vašem serveru. Je třeba panikařit? Co to znamená, co dělat a jak toto upozornění schovat? Více se dozvíte v tomto článku.

 

PHP, které je nainstalované na vašem serveru používají všechny weby a aplikace, které na daném serveru jsou, tudíž není vždy na místě provést aktualizaci, zejména proto, že některá rozšíření a verze Joomla! nemusí být s nejnovější verzí PHP kompatibilní. Taková aktualizace by pak měla za následek to, že starší weby přestanou fungovat nebo budou zobrazovat různá chybová hlášení.

Server s PHP 7

Pokud používáte Joomla 3 od verze 3.7.5 výš byste měli být v pohodě s PHP 7, ale nedá se říci, že váš web pojede bez problémů s PHP 7.1, protože pokud používáte např. eshop Virtuemart, nebo jiné rozšíření, které není plně kompatibilní s nejnovější verzí PHP, může vám přestat něco fungovat, nebo se rovnou zobrazí bílá stránka  s errorem.

PHP starší než PHP 7

Pokud používáte starší verzi PHP než 7, bylo by dobré z bezpečnostních důvodů verzi navýšit - pokud jsou na serveru všechny aplikace a weby s touto verzí kompatibilní. Máte-li tam např. weby na Joomla 2.5 nebo dokonce 1.5, je potřeba váš nový web na Joomla 3 přenést někam jinam - na server s PHP 7. Když už ne pro pocit bezpečí, tak proto, že po uvedení Joomla 4 vám stejně webové stránky v Joomla 4 nebudou fungovat s verzí PHP starší než PHP 7.

Každopádně, vzhledem k tomu, že Joomla 2.5 a 1.5 už dlouho nejsou podporované, a jsou tak snadno napadnutelné hackery, doporučujeme tyto zmigrovat na nejnovější Joomla! Pokud potřebujete s migrací starších verzí Joomla na nejnovější, případně redesignem webu pomoci, můžete se na nás s důvěrou obrátit.

Jak vypnout upozornění na verzi PHP v administraci Joomla!

V případě, že jste již vyřešili své vnitřní dilema a prozatím zůstanete u verze 7, a jen nechcete své klienty nebo sebe děsit tímto upozorněním, můžete ho snadno vypnout. Jděte do Rozšíření - Pluginy  a deaktivujte plugin Přímé odkazy - Kontrola verze PHP.

kontrola verze php

Mohlo by vás také zajímat...

Chcete se na něco zeptat?
1000 znaků zbývá