Neaktivní hodnoceníNeaktivní hodnoceníNeaktivní hodnoceníNeaktivní hodnoceníNeaktivní hodnocení
 

deprecated Joomla

Při pokusu nainstalovat webové stránky v Joomla! na server s php 5.6 nebo novějším se vám u starších instalačních balíčků může stát, že to vyhodí tyto chyby a nejde pokračovat v instalaci: Deprecated: iconv_set_encoding(). V tomto článku vám poradím, jak tento problém vyřešit.

Chyby, které se vám zobrazují mohou vypadat nějak takto:

Deprecated: iconv_set_encoding(): Use of iconv.internal_encoding is deprecated in ..\libraries\joomla\string\string.php on line 27
Deprecated: iconv_set_encoding(): Use of iconv.input_encoding is deprecated in joomlaroot\libraries\joomla\string\string.php on line 28
Deprecated: iconv_set_encoding(): Use of iconv.output_encoding is deprecated in joomlaroot\libraries\joomla\string\string.php on line 29

Na tento problém jsem narazila při instalaci šablony pro Joomla! z Templatemonster, protože Templatemonster svoje šablony neaktualizuje. Čili je potřeba po instalaci fullpackage balíčku zaktualizovat Joomla! i její rozšíření.

Jak tento problém vyřešit, abyste mohli pokračovat v instalaci Joomla!

1. Přihlaste se přes FTP a upravte soubor string.php v adresáři libraries\joomla\string\.

Jděte na řádek 27.

Tento kód:


if (function_exists(‘iconv’))
{
// These are settings that can be set inside code
iconv_set_encoding(“internal_encoding”, “UTF-8″);
iconv_set_encoding(“input_encoding”, “UTF-8″);
iconv_set_encoding(“output_encoding”, “UTF-8″);
}

změňte na:


if (PHP_VERSION_ID < 50600) {
iconv_set_encoding('input_encoding', 'UTF-8');
iconv_set_encoding('output_encoding', 'UTF-8');
iconv_set_encoding('internal_encoding', 'UTF-8');
} else {
ini_set('default_charset', 'UTF-8');
}

Nyní obnovte stránku s instalací Joomla!, chyby by měly zmizet a vy můžete pokračovat v instalaci webových stránek v Joomla!.

Mohlo by vás také zajímat...

Chcete se na něco zeptat?
1000 znaků zbývá